Back to overview
Resolved

Intermittent API errors and timeouts

Aug 6, 2026 at 1:00pm UTC
Affected services
app.getcargo.io

Resolved
Aug 6, 2026 at 3:30pm UTC

Resolved. Errors stopped at 15:30 UTC.

A large export could consume enough memory to take an instance down with it, which is what drove the restarts. Impact was intermittent rather than total: requests that landed on a healthy instance went through, and no data was lost. Instances settled fully over the evening.

We're changing exports to stream to storage rather than build the whole file in memory, which removes this failure mode.

Sorry for the errors you hit.

Created
Aug 6, 2026 at 1:00pm UTC

The API is returning intermittent errors and timeouts as instances restart. Requests may fail and then succeed on retry. We're investigating.